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1 Introduction 
 

Welcome to Korenix JetI/O 6500 Series Industrial Managed Ethernet I/O Module User 
Manual. Following topics are covered in this chapter: 

1.1 Overview of JetI/O 6500 Series 

1.2 Package Checklist 

1.3 JetI/O 6510 Introduction 

1.4 JetI/O 6510 Product Specification 

 

1.1 Overview of JetI/O 6500 Series 
 

JetI/O 6500 series is a series of Managed Ethernet I/O modules for distributive monitoring and 

controls. The JeI/O 6500 series equipped with one Ethernet port and multiple channels Analog 

Input/Output, Digital Input/Output and temperature measurement connectors. Thus users can easily 

perform I/O data collecting, status changing, automatically activate events… through the Ethernet 

network. JetI/O 6500 series provides Windows Utilities, Web and SNMP for configuration. And 

support Modbus/TCP protocol, OPC Server for Modbus/TCP, thus user can easily monitor and 

control the remote I/O devices and combine the JetI/O with existed HMI/SCADA package. 

 

Naming Rule:  JetI/O 65AB 
A: Major Feature  

1: Analog Input Series. Includes the RTD input, Thermocouple Input  

2: Analog Output Series  

3: Digital Input Series  

4: Digital Output Series  

5: Digital Input and Digital Output Series 

B: Sequence Number 

 

JetI/O 6500 Series includes: 
JetI/O 6510: Industrial Intelligent 8-CH Analog Input Etherent I/O Server 

JetI/O 6511: Industrial Intelligent 8-CH Thermocouple Input Etherent I/O Server 

JetI/O 6512: Industrial Intelligent 4-CH RTD Input Etherent I/O Server 

JetI/O 6520: Industrial Intelligent 4-CH Analog Output Etherent I/O Server 

JetI/O 6550: Industrial Intelligent 14-CH DI and 8-CH DO Etherent I/O Server 

The manual apply to above models. 
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1.2 Package Checklist 
Korenix JetI/O 6500 Series products are shipped with following items: 

 One Ethernet I/O Module 

 One attached DIN-Rail clip 

 Terminal Blocks for I/O and Power Input 

 Documentation and Software CD 

 Quick Installation Guide 

If any of the above items are missing or damaged, please contact your local sales 
representative. 

 

1.3 JetI/O 6520 Introduction 
JetI/O 6520 is an intelligent I/O Server equipped with one Etherent port and 4 channels 

Analog Output. Jet I/O 6520 provides 12 bits resolution and high accuracy for 

voltage/current output. Each AO channel equipped with the isolation of 2500Vms to 

protect your I/O server from damage, indepent output operation and 0.125 to 128 

programmable output slew rate are the best choice for analog output application. 

 

JetI/O 6520 provides Windows Utilities, SNMP and Web for configuration. Industrial 

Modbus/ TCP protocol and OPC Server driver for integrating JetI/O with existed 

HMI/SCADA. Robust aluminum case is with good heat dispersing and IP31 protection. 

With JetI/O users can easily perform status monitoring and control the remote I/O 

devices. 
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1.4 JetI/O 6520 Product Specification 
System Feature 

CPU: 16 bits/100MHZ, RISC-Based 
Network Protocols: IP, TCP, UDP, SNMP, HTTP, 
BOOTP, DHCP, Modbus/TCP, OPC Server 

SDRAM: 32K bytes 
Configuration: Windows Utility, Web browser, SNMP, 
DHCP Client, TFTP Server for firmware update 

Flash ROM: 512K bytes Windows Utility: Block I/O Utility, Device Fider Utility 

EEPROM: 256 bytes OPC Server Utiltity: OPC Server for Modbus/TCP 

Watchdog Timer: 1.0 sec H/W SNMP: MIB-II: System, SNMP Trap and Private MIB 

LED: SNMP Trap Server: Up to 4 SNMP Trap Server  

PWR: Power Input plugged and On (Red) 
Logic Condition&Go Rules: Conditions of the 
DI/Counter values, Actions include DO/Pulse, Counter 
and Trap 

RDY: System startup ready (Green) Program: C++ Example code by optional 

Network Interface Power Requirements 
Ethernet: IEEE 802.3 10Base-T System Power: external unregulated +24V (18-32V) 

IEEE 802.3u 100Base-TX Power Consumption: Max. 3.2W 

Connector: 1 * RJ-45, Auto MDI/MDI-X Mechanical 
Protection: Built-in 1.5 KV magnetic isolation 
protection 

Dimensions: 120 (H) x 55 (W) x 75 (D)mm 

LED: Mounting: Din-Rail 

Upper (LAN Activity): Orange ON & Blinking Material: Aluminum 

Lower (10M/100M): 10M à Green OFF, 100M à 
Green ON  

Environmental 

PWR: Power On (Green) Regulatory Approvals: CE, FCC Class A 

RDY: System boot up Ready (Red), system 
booting (No LED) 

Operating Temperature: -10 ~ 70°C 

Network Protocols: IP, TCP, UDP, SNMP, 
HTTP, Telnet, BOOTP, DHCP 

Operating Humidity: 20 ~ 90% non-condensing 

Analog Output  Storage Temperature: -20 ~ 70°C 

Output Channels: 4 Channels, differential Warranty: 3 years 

Resolution: 12 bits  

Output Range: ±10V, 0-10V, ±20mA  

Programmable Output Slope to Safety Value: 

0.125 to 128 mA/sec (Current) 

0.0625 to 64 V/sec (Voltage) 

 

Accuracy: ±0.05% of FSR ±1LSB  
Output Impedance: 0.5 ohm 

 

Current Load Resistor: 0 to 500 ohm 
Calibration: On Board EEPROM 

 

Isolation Voltage: 2500Vrms  
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2 Hardware Installation 
 

This chapter includes hardware introduction, installation and configuration information. 

Following topics are covered in this chapter: 

2.1 Hardware Introduction 

Dimension 

Appearance 

LED Indicators 

2.2 Wiring Power Input 

2.3 Wiring I/O Connectors 

2.4 Wiring Ethernet Ports 

2.5 DIN-Rail Mounting Installation 

 

2.1 Hardware Introduction 
Dimensions: 120 (H) x 55 (W) x 75 (D) mm 
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JetI/O 6520 Appearance: 

 

 
LED Indicators: 
 

System LED 

PWR Power Input plugged and On (Green) 

RDY System startup ready (Red) 

Ethernet LED 

Upper (LAN Activity) Orange On & Blinking 

Lower(10M/100M) 10M (Green Off) /100M(Green ON 

 

2.2 Wiring Power Input 
Follow below steps to wire JetI/O DC power inputs. 
1. Follow the pin assignment to insert the wires into the contacts on the terminal block 

connector. 

2. Tighten the wire-clamp screws to prevent DC wires from being loosened. 

3. Connect to and turn on the power source. The suitable working voltage is 24VDC. 

4. When the unit is ready, the PWR LED turns Greed, the RDY LED turns Red. 

Note1: It is a good practice to turn off input and load power, and to unplug power terminal 
block before making wire connections. Otherwise, your screwdriver blade can 
inadvertently short your terminal connections to the grounded enclosure. 

Note 2: The range of the suitable electric wire is from 12 to 24 AWG. 
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2.3 Wiring I/O Connectors 
Follow the pin assignment to insert the wires into the front contacts on the terminal block 
connector. Tighten the wire-clamp screws to prevent the I/O wires from being loosened. 

The wiring diagram of the JetI/O 6520 is as below:  

 
2.4 JetI/O 6520 Wiring Example 
2.4.1 JetI/O 6520 voltage output wiring example 

 
2.4.2 JetI/O 6520 current output wiring example 

 

Pin No Description Pin No Description 

1(Vout0) CH0 Voltage Output 9(Vout1) CH1 Voltage Output 

2(AGND) Analog GND 10(AGND) Analog GND 

3(Iout0+) CH0 Current Output + 11(Iout1+) CH1 Current Output + 

4(Iout0-) CH0 Current Output - 12(Iout1-) CH1 Current Output - 

5(Vout2) CH2 Voltage Output 13(Vout3) CH3 Voltage Output 

6(AGND) Analog GND 14(AGND) Analog GND 

7(Iout2+) CH2 Current Output + 15(Iout3+) CH3 Current Output + 

8(Iout2-) CH2 Current Output - 16(Iout3-) CH3 Current Output - 
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2.5 Wiring Earth Ground 
To ensure the system will not be damaged by noise or any electrical shock, we suggest 
you to make exact connection with JetI/O products with Earth Ground. 

On the bottom side of JetI/O 6500 Series, there is one power earth ground pin in the 
Power Input terminal block. 

 

 

2.6 Wiring Fast Ethernet Ports 
JetI/O 6500 series includes 1 RJ45 Fast Ethernet ports. The fast Ethernet ports support 
10Base-T and 100Base-TX, full or half duplex modes. The fast Ethernet port will 
auto-detect the signal from connected devices to negotiate the link speed and duplex 
mode. Auto MDI/MDIX allows users to connect another switch, hub or workstation without 
changing straight through or crossover cables. 

Connect one side of an Ethernet cable into the Ethernet port and connect the other side to 
the attached switch or host. The link LED will light up when the cable is correctly 
connected. Refer to the LED Indicators section for descriptions of each LED indicator. 
Always make sure that the cables length between the 2 ends is less than 100 meters (328 
feet). 

The wiring cable types are as below. 

10Base-T: 2-pair UTP/STP Cat. 3, 4, 5 cable, EIA/TIA-568 100-ohm (100m) 
100 Base-TX: 2-pair UTP/STP Cat. 5 cable, EIA/TIA-568 100-ohm (100m) 
1000 Base-TX: 4-pair UTP/STP Cat. 5 cable, EIA/TIA-568 100-ohm (100m) 
 

2.7 Din-Rail Mounting Installation 
The DIN-Rail clip is already attached to the JetI/O 6500 Series when packaged. If the 
DIN-Rail clip is not screwed on the JetI/O, follow the instructions and the figure below to 
attach DIN-Rail clip to JetI/O. 

a. Insert the upper end of DIN-Rail clip into the back of DIN-Rail track from its upper side. 

 
b. Lightly push the bottom of DIN-Rail clip into the track. 

Pin No Description 
1(+24V) DC+24V Power Input 
2(FGND ) Power Earth Ground 
3(0V) Referenced Ground for Power Input 
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c. Check if DIN-Rail clip is tightly attached on the track. 
d. To remove JetI/O 6500 from the track, reverse the steps above. 
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3 Preparation for Management 
Before you start to configure the JetI/O, you need to know the system architecture of the 
JetI/O products, configure the device’s IP address, and then you can remotely manage 
the Ethernet I/O via the network. This chapter introduces the basic knowledge of the 
related technologies. 

Following topics are covered in this chapter: 

3.1 Understand the Intelligent Ethernet I/O Server Architecture 

3.2 Preparation for Remote Management 

3.3 Preparation for HMI/SCADA Integration 

 

3.1 Understand the Ethernet I/O Server Architecture 
 

The Figure 1 shows the JetI/O Intelligent Ethernet I/O Server Architecrure. In the top level 

shows the typical applications run in the remote I/O environment. The middle level is the 

Etherent infrasture. The low level, gray block include the software agent, signal types of 

the JetI/O 6500 series intelligent Etherent I/O Server. 

 

 

Figure 1. The JetI/O Intelligent Ethernet I/O Server Architecrure. 

 

3.2 Preparation for Remote Management 
JetI/O 6500 series Intelligent I/O Server provides several types remote management 
methods. You can configure the JetI/O via the Etherent network. You just need to know 
the device’s IP address and then you can remotely control or monitor the I/O channels’ 
information.  

JetI/O provides several ways for users to configure the IP address. The default IP 
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address is 192.168.10.3. You can directly connect the JetI/O one after one to change its 
IP address. Or connect the JetI/Os to the same switch or network, then the host PC can 
modify the IP address via the switch or network. 

 

If you purchase several JetI/Os and connect them to the same network before change 
their IP address. They must have the same default IP address, and you may not control 
them well due to the IP conflict. At this time, you should change their IP address first. 
The JetI/O’ Block I/O configuration utility or Device Finder Utility can help you to do this. 

Note 1: Device Finder Utility allows you to discover the JetI/Os which have the same IP 
address. Change the IP address of the JetI/O one after one. After you configured the 
new IP address for the unit, please notice whether the ARP table of the device is flashed 
or not. If not, you can choose “Start -> Run”, type “cmd” to open the DOS prompt. Use 
“arp –d” to clear the ARP cache. 

Note 2: You can find the detail progress, please refer to the next chapters. 
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4 Feature Configuration 
JetI/O 6500 series Industrial Managed Ethernet I/O module provides several 
configuration methods. This chapter introduces the configuration steps.  

Following topics are covered in this chapter: 

4.1 Block I/O Configuration Utility 

4.2 Block I/O OPC Server Utility 

4.3 Device Finder Utility 

4.4 SNMP  

4.5 Web UI  

4.6 Modbus/TCP Command set 

4.6.1 Introduction of Modbus/TCP protocol 

4.6.2 JetI/O 6510 Modbus/TCP command set 

 

4.1 Block I/O Configuration Utility 
 

Block I/O Utility is the major JetI/O Configuration Utility. With this tool, you can browse 
the available units, view the status of each channel, configure the I/O settings, configure 
active alarms and conditions&Go logic rule. 

4.1.1 Installation 

1. Go to the “Utility -> IO Configuration” folder. Click “Setup.exe” to run the setup 
progress. 

 

2. Click “Next” and type the Name and Company in the “User Information” window. Then 
click “Next”. 

3. Choose the Destination Directory in the “Choose Installation Location” window. Then 
click “Next”. 
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4. Type the name for the Block I/O Configuration Utility or use the default name, Block 
IO Utility (Korenix) for the program in the “Program Folder” field of the “Select Program 
Folder” window. Then click “Next”. 

5. Click “Next” in the “Starting Copying File” window to continue the setup progress. 

6. As long as you see the “Setup Complete” window that means the progress is finished. 
Click “Finish” to exit the setup progress. 

7. Go to “Start” -> “Program”, then you can see the “Block IO Utility(Korenix) folder. 
There are 2 utilities are installed, Block IO OPC Server and Block IO Utility. 
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4.1.2 Device Scan 

1. Lunch the Block IO Utility and then press “Open” to enable the network Interface. 

The right indicator will show “Green” after you opened the interface. Click “Cloos” can 
close the network interface. 

2. Click “Scan” to open the “Scan Network Module(s)” popup window. Click Scan to start 
the searching. 
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Note: Please modify the IP address of your target devices. The scan feature can’t 
browse the devices which have the same IP address. Only one of the devices which 
have the same IP address can be found. This is the current restriction. Please modify 
the IP address first. You can use web browser, Block I/O Utility or Device Finder to do 
the IP modification. 

3. Click “Add” to add the available JetI/O units. Then you can see the JetI/O units are 
listed in the left column. 

 

4. Move the mouse over to one of the JetI/O units. Select the unit then you can configure 
and monitor the configurations of the JetI/O. The features Block I/O Configuration utility 
provide are similar, please find your model name and go to its configuration introduction 
chapter in below. 

 

4.1.3 JetI/O 6520 Configuration 

4.1.3.1 Go to “General” page. You can view the current settings, modify the IP address, 
Subnet mask, Default Gateway, Enable or Disable DHCP Client mode, set output 
range, set slew rate and check the Firmware version. After modified the network 
setting, press “Update” to active the new setting. The indicator will show green 
when update successfully. 
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Set Output Range 

Click Set Output Range to configure the output range of each channels. 

 

Set Slew Rate 

Click “Set Slew Rate” to configure the slew for voltage/current output. The value is 
depended on what kinds of the application you connect. For some motors, they 
may not receive immediate output change, you can use slew to activate them with 
high/small slew rate. 

 

4.1.3.2 Go to “Analog Output” page. You can configure the output range and value for 
each channel. Click Update 0/1/2/3 then the new settings are activated. 
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4.2 Block I/O OPC Server Utility 
4.2.1 OPC Server Utility 

1. Go to “Start” -> “Program”, then you can see the “Block IO Utility(Korenix) folder. 
There are 2 utilities are installed, Block IO OPC Server and Block IO Utility. 

2. Open the “Block IO OPC Server”. 

3. Select “File -> New” to create new profile. Or select “File -> Open” to open profile you 
saved.  

 

4. Select “Add -> New Device”, the popup window “Driver Selection” will appear. (Only 
appear in the first time you add new device). Click “Add” and type the driver name and 
correct IP address. Click “OK” to next popup windows for Driver Selection. Use “Edit 
-> Comm Setting” can modify the parameters. 
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Figure 4.1  “Add” the “New Device”. 

 

Figure 4.2 Installed Driver Selection Window. 

Figure 4.3 “Ethernet Driver” for the devices. 

 

5. Type the “Device Name” and select the “Device Type” in the “Device Configuration” 
window.  
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6. Select “Add -> New Group” to create new group for the later new tags you’ll create. 
Select “Add -> New Tag” and fill the “Tag Properties” in the popup window. Select the 
tag and “Edit –> Properties“, you can modify the tag properties. 

 

7. Select “Add -> Generate Tags”, the utility generate all the channels’ tags for the 
device. 

Name: The name of the channel. You can manually change this value. 

Type: The input type of the channel. 

Channel: The channel ID. 

Value: The value of the channel, you can use “Monitor” to read them. 

Description: The description of this channel, you can munually change this value. 

 

8. Select “View -> Monitor” to monitor the status of the tags.     Or you can click the 

Monitor icon in the UI. 

9. Select “File -> Save” to save the profile, then your OPC Client can monitor the Jet I/O 
status. 
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4.3 Device Finder Utility 
1. Go to the “Utility -> Device Finder” folder. Click “DeviceFinder.exe” to run the program. 

 

2. Click “Setting” of the DF Setting, you can configure the polling period time. 

3. Click “Setup” of the EEPROM, you can see the info of the device. It’s good to do 
debugging. 

4. Click “Search”, Device Finder can automatically search the JetI/Os. 

5. Click “IP Search” to search one specific IP address. 

6. Click “Device Setup” to configure the IP address… basic network settings. 

7. Click “Web Browser” to connect the web UI of the device. 

8. Click “Reboot” to reboot the device. 

9. Click “Upgrade” to upload the new firmware.  

10. Click “Exit” to exit the program. 

 

4.4 SNMP 
Simple Network Management Protocol (SNMP) is a protocol used for exchanging 
management information between network devices. SNMP is a member of the TCP/IP 
protocol suite. JetI/O 6500 series support SNMP v1 and v2c. 

An SNMP managed network consists of two main components: agents and a manager. An 
agent is a management software module that resides in a managed switch. An agent 
translates the local management information from the managed device into a SNMP 
compatible format. The manager is the console through the network. 

JetI/O 6500 series supports Public MIB: System. Private MIB includes channels’ 
information. SNMP Trap allows the JetI/O to send the active alarm to trap servers. 
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4.5 Web UI 
Type the IP address of the device. Then you can access the embedded web browser of 
the I/O server. The web browser allows you monitor the information/status of each 
channels. 

 

4.6 How to Upgrade Firmware 
The JetI/O server allows you remotely upgrade the firmware to fix the known issues or to 
enhance the software features. When user starts the progress of the firmware upgrade, 
the JetI/O runs as the DHCP client mode to get the IP from DHCP Server and download 
the boot file from the server. (Not the same as JetNet or other product.) 

For JetI/O firmware upgrading utility, we recommend the freeware utility, TFTP32. You can 
easily download the tool in the web site: http://tftpd32.jounin.net/  

1. Download the file and run it first. 

2. Browse the “Current Directory” of the firmware file you put. And select the network 

interface card you used. 

3. Configure the setting in the “DHCP Server” mode.  

a. Type the start IP address in the “IP pool starting address”. 

b. Type the volume for the Size of the pool. The volume is the IP address the 

DHCP Server can assign to the clients.  

c. Boot File: Type the file name you want update. 

d. Mask: Type the subnet mask here. 

e. The other settings are optional, depend on your environment. 

f. After configured, press “Save” to save the settings.  

 

 

4. Open the Device Finder Utility and search the available JetI/O servers. Select the 
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target unit/units you want upgrade. Then press “Upgrade” to start the progress. The 

JetI/O can get dynamic IP and download file from the TFTP32. The popup window 

shows you the upgrading progress in TFTP32. 

5. After firmware file downloading finished. The JetI/O server’s firmware can be 

upgraded automatically. 

6. Open the Block I/O Configuration utility and check the firmware in “General” page. 
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5 Modbus/TCP Command Set 
This chapter introduces the Modbus/TCP command set JetI/O provided. When you 
creating application for your SCADA/HMI or coding your own programs. The command 
set is helpful for you to find the value of each registers. 

Following topics are covered in this chapter: 

5.1 Introduction of Modbus/TCP Protocol 

5.2 JetI/O 6520 Modbus/TCP Address Mapping 

 

5.1 Introduction of Modbus/TCP Protocol 
5.1.1 Modbus/TCP Protocol 

The Modbus protocol, developed by Gould-Modicon, is widely used in industrial 
communications to integrate PLC’s, computer, terminals and other various I/O devices. 
Intelligent JetI/O Server equipped with communication interface provides an Ethernet 
communication links with Modbus/TCP protocol support. 

Modbus/TCP is a variant of the Modbus family of communication protocol.  Modbus/TCP 
is a Master/Slave communication protocol. A master (a host PC) initiates queries, a slave 
(one of the JetI/O servers) then responds by supplying the requested data to the master by 
using Modbus/TCP commands. 

 

5.1.2  Function Code (FC) 

The Intelligent JetI/O Server uses a subset of the standard Modbus/TCP function code to 
access device-dependent information. Modbus/TCP function code is defined as below. 

FC Name Usage 

01 Read Coils Read the state of a digital output 

02 Read Input Status Read the state of a digital input 

03 Read Holding Register Read holding register in 16-bits register format 

04 Read Input Registers Read data in 16-bits register format 

05 Write Coil Write data to force a digital output ON/OFF 

06 Write Single Register Write data in 16-bits register format  

15 Force Multiple Coils Write data to force multiple consecutive coils 
 

5.1.3  Error Checking 

The utilization of the error checking will help eliminate errors caused by noise in the 
communication link. In Modbus/TCP mode, messages include an error-checking field that 
is based on a Cyclical Redundancy Check (CRC) method. The CRC filed checks the 
contents of the entire message. It applied regardless of any parity check method used for 
the individual BYTE acters of the message. The CRC value is calculated by the 
transmitting device, which appends the CRC to the message. The receiving device 
recalculates a CRC during receipt of the message, and compares the calculated value to 
the actual value it received in the CRC filed.  
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5.1.4  Exception Response 

If an error occurs, the slave sends an exception response message to master consisting of 
the slave address, function code, exception response code and error check field. In an 
exception response, the slave sets the high-order bit (MSB) of the response function code 
to one. The exception response codes are listed below. 

 

Code Name Descriptions 

01 Illegal Function The message function received is not allowable 

action. 

02 Illegal Data Address The address referenced in the data field is not valid.

03 Illegal Data Value The value referenced at the addressed device 
location is no within range. 

04 Slave Device Failure An unrecoverable error occurred while the slave 
was attempting to perform the requested action. 

05 Acknowledge The slave has accepted the request and processing 
it, but a long duration of time will be required to do 
so. 

06 Slave Device Busy The slave is engaged in processing a long-duration 
program command. 

07 Negative Acknowledge The slave cannot perform the program function 
received in the query. 

08 Memory Parity Error The slave attempted to read extended memory, but 
detected a parity error in the memory. 

 

5.2 JetI/O 6520 Modbus/TCP Address Mapping 
JetI/O 6520 Common Register Map (Holding Registers) 

Protocol 
Address 

(Hex) 

PLC 
Address 
(Decimal) 

 
Access 

 
Description 

0000 40001 R/W (Read/Write)  Watch-dog  enable/disable 
R/W:AABB  
AABB:0000H    (disable) 
AABB:FF00H    (enable) 

0001 40002 R/W (Read/Write) Watch-dog cycle count 
R/W:AABB  
AABB:0001H~00FFH     
BB:1 ~255  BB x 0.1 (sec)=count cycle (sec) 

0002 40003 R/W R: Read the host-watchdog status 
W: Reset the host-watchdog status 
R:AABB  
AABB:0000H  (remote module OK) 
AABB:FF00H  (host-watchdog fail) 
W: AABB 
AABB:FF00H(reset) 

0003 40004 R Read the firmware version 
R:AAAA 
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AAAA:F20A (HEX)   
0004 40005 R Read module name 

R:AAAA 
AAAA: 6520 (HEX) 

0005 40006 R Read reset status 
R:AABB 
AABB:0000H ( after using this read command) 
AABB:0001H(The value is equal to0001H after reset 

module) 
0006 40007 R R: always 0 
0007 40008 R R: always 0  
0008 40009 R/W Read/Write DA Slew Rate Code 

R: Read slew rate 
W: Write slew rate 
R:ABCD  
W:ABCD 
A:0~B for channel 3 (ref. the following Table A) 
B:0~B for channel 2 
C:0~B for channel 1 
D:0~B for channel 0 
0:immediate change 

0009 40010 R/W Output range (address low byte)   
Code:0~2 
R/W:ABCD 
A:0~2 for Channel 3  
B:0~2 for Channel 2  
C:0~2 for Channel 1 
D:0~2 for Channel 0  
0: 0~+10V   1: -10V~+10V    2: 0~20mA 

000A 40011 R/W Read/Write power on DA value of channel 0  
R:0AAA 
AAA: Hexadecimal DA value  
Write present DA value as power on value of channel 0 
W: AABB  
AABB:FF00H  

000B 40012 R/W Read/Write power on DA value of channel 1 
R:0AAA 
AAA: Hexadecimal DA value   
Write present DA value as power on value of channel 1 
W: AABB 
AABB:FF00H 

000C 40013 R/W Read/Write power on DA value of channel 2  
R:0AAA 
AAA: Hexadecimal DA value   
Write present DA value as power on value of channel 2 
W: AABB 
AABB:FF00H 

000D 40014 R/W Read/Write power on DA value of channel 3  
R:0AAA 
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AAA: Hexadecimal DA value   
Write present DA value as power on value of channel 3 
W: AABB 
AABB:FF00H 

000E 40015 R/W Read/Write DA offset Calibration Coefficients of channel 
#0 
R:AABB  
AABB: offset Calibration Coefficient value 
W: FF00H (offset Calibration)   

000F 40016 R/W Read/Write DA span Calibration Coefficients of channel 
#0 
R:AABB  
AABB: span Calibration Coefficient value 
W: FF00H (span Calibration) 

0010 40017 R/W Read/Write DA offset Calibration Coefficients of channel 
#1 
R:AABB  
AABB: offset Calibration Coefficient value 
W: FF00H (offset Calibration)   

0011 40018 R/W Read/Write DA span Calibration Coefficients of channel 
#1 
R:AABB  
AABB: span Calibration Coefficient value 
W: FF00H (span Calibration) 

0012 40019 R/W Read/Write DA offset Calibration Coefficients of channel 
#2 
R:AABB  
AABB: offset Calibration Coefficient value 
W: FF00H (offset Calibration)   

0013 40020 R/W Read/Write DA span Calibration Coefficients of channel 
#2 
R:AABB  
AABB: span Calibration Coefficient value 
W: FF00H (span Calibration) 

0014 40021 R/W Read/Write DA offset Calibration Coefficients of channel 
#3 
R:AABB  
AABB: offset Calibration Coefficient value 
W: FF00H (offset Calibration)   

0015 40022 R/W Read/Write DA span Calibration Coefficients of channel 
#3 
R:AABB  
AABB: span Calibration Coefficient value 
W: FF00H (span Calibration) 

0016 40023 R/W Analog output voltage of Channel #0 
Note: 
R: read last DA output voltage value  
W: AAAA 
AAAA: 0~10000 means (0~10V) for output range=0 
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AAAA: -10000~10000 means (-10~10V) for output 
range=1 
AAAA: 0~20000 means (0~20mA) for output range=2 

0017 40024 R/W Analog output voltage of Channel #1 
Note: 
R: read last DA output voltage value 
W: AAAA 
AAAA: 0~10000 means (0~10V) for output range=0 
AAAA: -10000~10000 means (-10~10V) for output 
range=1 
AAAA: 0~20000 means (0~20mA) for output range=2 

0018 40025 R/W Analog output voltage of Channel #2 
Note: 
R: read last DA output voltage value  
W: AAAA 
AAAA: 0~10000 means (0~10V) for output range=0 
AAAA: -10000~10000 means (-10~10V) for output 
range=1 
AAAA: 0~20000 means (0~20mA) for output range=2 

0019 40026 R/W Analog output voltage of Channel #3 
Note: 
R: read last DA output voltage value 
W: AAAA 
AAAA: 0~10000 means (0~10V) for output range=0 
AAAA: -10000~10000 means (-10~10V) for output 
range=1 
AAAA: 0~20000 means (0~20mA) for output range=2 

001A 40027 W Positive Trim operation of channel N 
W:0ABB 
A: Channel number (0~3) 
BB: Trim count(00~FF) 

001B 40028 W Negative Trim operation of channel N 
W:0ABB 
A: Channel number (0~3) 
BB: Trim count(00~FF) 

 

Table A. DA Slew Rate Code 

 

DA Slew Rate Code 

Code +10V -10V∼+10V 20mA 

 V/sec V/sec mA/sec 

0000 Immediate Change 

0001 0.0625 0.125 0.125 

0010 0.125 0.25 0.25 

0011 0.25 0.5 0.5 

0100 0.5 1.0 1.0 
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0101 1.0 2.0 2.0 

0110 2.0 4.0 4.0 

0111 4.0 8.0 8.0 

1000 8.0 16.0 16.0 

1001 16.0 32.0 32.0 

1010 32.0 64.0 64.0 

1011 64.0 128.0 128.0 

 

Table B. D/A Calibration 

Output 

Range(Hex) 

Zero Calibration  

 Voltage/current 

Span Calibration 

 Voltage/current 

0 1v  9v 

1 -8v  8v 

2 2mA  18mA 
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6 Appendix 

6.1 SNMP MIB 

An SNMP to I/O MIB file that can help you monitor I/O status with SNMP software. You 

can find the MIB file on the package. 

 (I). Public- System MIB:  

Object ID 
(OID) 

Description Community, 
R/W Access 

sysDescr The sysDescr directive is used to define the system 

description of the host on which the SNMP agent 

(server) is running. This description is used for the 

sysDescr object instance of the MIB-II. 

SYNTAX: DisplayString (SIZE (0..31)) 

Public, 

Read Only 

sysObjectID The vendor's authoritative identification of the 

network management subsystem contained in the 

entity. This value is allocated within the SMI 

enterprises subtree. 

SYNTAX: DisplayString (SIZE (0..31)) 

Public, 

Read Only 

sysUpTime The sysUpTime directive is used to measures the 

time, in hundredths of a second, since the last 

system restart. 

SYNTAX: DisplayString (SIZE (0..31)) 

Public, 

Read Only 

sysContact The sysContact directive is used to define the system 

contact address used for the sysContact object 

instance of the MIB-II. 

SYNTAX: DisplayString (SIZE (0..31)) 

Public, 

Read Only 

sysName The sysName directive is a string containing an 

administratively-assigned name for the system 

running the SNMP agent. By convention, this should 

be its fully-qualified domain name. 

SYNTAX: DisplayString (SIZE (0..31)) 

Public, 

Read Only 

sysLocation The sysLocation directive is used to define the 

location of the host on which the SNMP agent 

(server) is running. This directive is used for the 

sysLocation object instance of the MIB-II. 

Public, 

Read Only 
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SYNTAX: DisplayString (SIZE (0..31)) 
 

 (II).Private MIB - Intelligent I/O Server - 6520 

  

Object ID (OID) Description Community, 
R/W Access 

eioAout00Value 

 

Analog Output signal (Channel 0) 

SYNTAX: INTEGER ( 0..65535 ) 

Private, 

Read/Write 

eioAout01Value 

 

Analog Output signal (Channel 1) 

SYNTAX: INTEGER ( 0..65535 ) 

Private, 

Read/Write 

eioAout02Value 

 

Analog Output signal (Channel 2) 

SYNTAX: INTEGER ( 0..65535 ) 

Private, 

Read/Write 

eioAout03Value 

 

Analog Output signal (Channel 3) 

SYNTAX: INTEGER ( 0..65535 ) 

Private, 

Read/Write 

 

 

6.2 Revision History 
Version Description Date 

0.1 First draft version. Jan. 10, 2008 

   

   

 
 


